Downloading Attachments Results in java.net.SocketException Connection Reset

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Downloading attachments fails displaying the error in the JIRA logs:

2007-07-13 14:31:15,851 TP-Processor1 ERROR [jira.web.servlet.ViewAttachmentServlet] Error finding /10015/screenshot-2.jpg: null
ClientAbortException: java.net.SocketException: Connection reset
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:366)
at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)
....
Caused by: java.net.SocketException: Connection reset
at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)
at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
at org.apache.jk.common.ChannelSocket.send(ChannelSocket.java:531)
at org.apache.jk.common.JkInputStream.doWrite(JkInputStream.java:147)
at org.apache.coyote.Response.doWrite(Response.java:559)
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffer.java:361)
... 50 more

Cause

There are four possibilities that could be causing this error:

  1. The firewall may have been configured incorrectly ultimately rejecting the attachment.
  2. There is a flaky connection while accessing JIRA.
  3. The attachments directory may have been moved.
  4. User has closed their browser in the midst of viewing an attachment

Resolution

  1. Check system's firewall settings to make sure that JIRA has access to add the attachments.
  2. Ensure that there is no packet loss or dropped connections. A good tool to test this with would be WireShark.
  3. Check to make sure that the attachments directory is configured correctly.

Last modified on Feb 7, 2017

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.