Drop-Down Menus Look Broken after JIRA 4 Upgrade
Symptoms
Drop down menus from the header which contain icons look broken as the icons keep repeating throughout the menu items:
Cause
This is caused by a missing property in the jira-application.properties
file (jira.lf.application.id
). This would have happened when the instance was upgraded to 4.0, but the old jira-application.properties file was not merged with the new one.
Workaround
The jira-application.properties
file must be modified to contain all the necessary new entries. Follow these steps:
- Obtain a copy of the new (clean)
jira-application.properties
from the JIRA download. In the Standalone download, you will find the file in./atlassian-jira/WEB-INF/classes/jira-application.properties
- Back up the existing
jira-application.properties
file. - Use a diffing tool to compare the two files. We want to merge any changes from the old properties file onto the new one (i.e. we are changing the new file, leaving the old untouched). If you're using Windows, a good diff tool is WinMerge.
- For any property entry that has changed between the old and new file, copy the old value over to the new property entry.
- Make sure to do any comparisons on a line-by-line basis: some diff tools might compare 1 line to many lines because the first line had changed and the rest were either added or deleted.
- At the end of the procedure, your new properties file should be correctly modified with any old property values.
- Once you have a new
jira-application.properties
file, install it into the instance, overwriting the existing file. - Restart JIRA to see the changes.
Resolution
Follow the standard upgrade documentation which prescribes using a new distribution of JIRA along with an XML backup.