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Symptoms

When creating a draft workflow, a stack trace containing a message like the following is returned to the web browser:

Cause

This can occur when the creation of a draft workflow is simultaneously initiated by the same or different administrative accounts.

JRA-40009 - Prevent JIRA from creating duplicate draft workflows Resolved

Resolution

Always backup your data before performing any modifications to the database.

  1. Run the following SQL query to identify the drafts with more than one entry:

  2. Delete one of them.

  3. Restart JIRA.

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9 Comments

  1. The workaround isn't useful in enterprise situations where a restart is a rare event. From the description this is a bug in the workflow admin - is there an issue in jac for this?

    1. I'm agree with Matt, should be whether a workaround with no restart required or a defect to fix.

      Just hit this issue on JIRA 6.2.3, our admin has clicked "Create draft" twice within 1.5sec (according to meta data in xmls). And after this, we cann't edit a workflow.

  2. What is the solution for OnDemand instances where access to database is not possible?

    1. I've found a creative but not ideal solution which is to copy the workflow as the copy has no drafts associated with it.

  3. There is a workaround with no restart -> try to copy the workflow you want edit. You can edit the copy and then migrate the workflow schema.

    1. Sadly, you then have an inactive workflow that can't be deleted for the same reason.


      Why can't Atlassian address this?  Surely deleting an inactive workflow with multiple drafts can just happen?

  4. Thank you for the solution, it works for me, even without restart

  5. Just came across this as well, and it is unfortunately not the first time I have to access the database directly to solve and issue (sad) Hopefully Atlassian will solve these issues.

  6. I wouldn't say this is "extremely rare". Its quite common actually. Its occurred for us several times, and we don't change workflows that often.