Gadgets Showing Incorrect Issue Count for Versions

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

A gadget's issue count when filtering by Versions does not match the actual issues returned when viewing the filter.

Cause

From the database end, tickets are linked to versions that may not actually exist.

Resolution

This will have to be resolved from the database side:

Backup the database before attempting any changes.

  • First verify if there are issues associated with non-existing versions:
  • Query to see if any defined Fix Versions do not actually exist:

    select count(*) from nodeassociation where sink_node_id not in (select id from projectversion) and association_type = 'IssueFixVersion';
  • Query to see if any defined Affects Versions do not actually exist:

    select count(*) from nodeassociation where sink_node_id not in (select id from projectversion) and association_type = 'IssueVersion';
  • If either of the above query return results, then that is verification of issues associated with non-existent versions.
  • At this point, a DELETE statement can be run to remove these invalid entries.
Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.