Greenhopper plugin upgrade task failed
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When preforming a plugin upgrade through the UPM the upgrade task has failed silently and the plugin is not behaving correctly. This is because the failure is not notifying the user throught the GUI. This is a generic error what could be covering a wilde array of plugins but would likely be affecting the Greenhopper 5.8 plugin upgrade.
The following appears in the atlassian-jira.log
:
1
[sal.core.upgrade.DefaultPluginUpgradeManager] Upgrade error
Cause
A plugin upgrade, likely Greenhopper 5.8, has failed and needs to be looked into from an Atlassian support technician
Resolution
Please contact support@atlassian.com and log a ticket in https://support.atlassian.com for a support engineer to analyse your problem and see how it could be best resolved.
Ensure you have attached the entirety of your latest JIRA logs ({{$JIRA_HOME/log/atlassian-jira.log}})
Also your application server log files:
UNIX: {{$JIRA_INSTALL/logs/catalina.out}}
Windows: {{$JIRA_INSTALL/logs/stdout}} and {{stderr}}
If in doubt, please attach everything, problems are resolved much faster when logs are provided.
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