How to fix Jira Service Management StatusPage stuck load when in configuration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The StatusPage configuration gets stuck not allowing the plugin configuration

Environment

8.20.8

Diagnosis

By running a Har file, a status 500 is presented as the call below:

Har File

1 2 3 4 Request URL: https://<jira-base-url/rest/statuspage/1.0/config/project/service_desk Request Method:GET Status Code:500 Remote Address: 171.15.43.83:80

Going through the application log we can see the error:

application log

1 2 2023-03-17 12:25:18,587-0300 http-nio-8080-exec-384 ERROR admin 745x6538866x6 w59hbr X.X.X.X,X.X.X.X /rest/statuspage/1.0/config/project/service_desk [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: null java.lang.NullPointerException

Cause

The issue is caused due to invalid entries in the table AO_050302_STATFL_CONF, related to projects that no longer exist.

Solution

The solution is based in removing directly from the database the incorrect entries.

PLEASE READ: As with all recommendations made by Atlassian Support, please follow best practices for Change Management and make sure to test and validate these steps in a lower environment (staging, development, testing, etc) prior to rolling any changes into a Production environment, and only after backing up your system and data. This is to validate these changes and ensure that they will function well within your infrastructure prior to placing them in production.

1 - Execute the SQL query below and check if all the entries in the table AO_050302_STATFL_CONF are associated with projects that currently exist - if you find any entry related to a project that no longer exists, please remove that by running the SQL query (indicated below).

1 select * from "AO_050302_STATFL_CONF";

2 - Stop Jira

3 - Run the SQL query to delete the invalid entry

1 delete from "AO_050302_STATFL_CONF" where "PROJECT_NAME"='<PROJECT_NAME>';

Replace the <PROJECT_NAME> with the name of the Project that no longer exist

4 - Start Jira

5 - Run the Database Integrity Checker.

More information

This article is related to the Feature Request:

Updated on March 24, 2025

Still need help?

The Atlassian Community is here for you.