How to fix missing Epic Link suggestions in Jira
Platform Notice: Data Center and Cloud By Request - This article was written for the Atlassian data center platform but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This article instructs how to fix the missing Epic Link suggestions in Jira under the "Epic Link" field
Environment
9. X Versions of Jira
Diagnosis
Users are unable to link epics to stories as Epic suggestions are not visible. Epics are only visible when selecting "Show Done Epics," but those epics are actually not in the Done state.
Cause
Epic suggestions are not visible under the "Epic Link" field of an issue due to stale indexes.
Solution
There's a likelihood that Epics are not visible under the "Epic Link" field suggestions because the indexes are not up to date.
Run a Full re-indexing to mitigate the issue.
Go to (you can search for it by pressing '.')
> System > IndexingChoose Full reindex.
After the full re-index process is completed, Validate whether epic suggestions start to work under the issue( story) "Epic Link" field.
If the full re-index doesn't help. please reach out to Atlassian Support via this link.