Incomplete CSV Import when Issue Type Is Not Properly Defined

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Issue import from CSV file fails with the following message reported in the application logs:

2008-03-03 11:33:16,078 Thread-36 INFO [imports.importer.impl.ImportLogger\] com.atlassian.jira.external.ExternalException: Unable to create issue: Issue {summary=ABC, type=null}
	at com.atlassian.jira.external.ExternalUtils.createIssue(ExternalUtils.java:312)
	at com.atlassian.jira.imports.importer.impl.DefaultJiraDataImporter.importIssues(DefaultJiraDataImporter.java:479)
	at com.atlassian.jira.imports.importer.impl.DefaultJiraDataImporter.doImport(DefaultJiraDataImporter.java:125)
	at com.atlassian.jira.imports.importer.impl.ImporterThread.run(ImporterThread.java:21)
Caused by: com.atlassian.jira.imports.csv.ImportException: No default issue type found for project: TESTING

Cause

The Issue Type Scheme applied to the target Project does not specify a default issue type, and the CSV file does not define an Issue Type attribute for all issues to be imported.

Resolution

There are two possible solutions to this problem:

  1. Set a default issue type in the Issue Type Scheme of the target Project (see the following documentation for details: Associating Issue Types with Projects)
  2. Define an Issue Type field in every issue in the CSV that is to be imported into JIRA and specify a Field Value Mapping in the CSV configuration wizard.

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.