Internal server error when opening Sprint Report

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Users are unable to access the Sprint reports on Rapid Board and the following appear in the log files:

com.sun.jersey.server.impl.application.WebApplicationImpl onException
SEVERE: Internal server error
java.lang.NullPointerException
at com.atlassian.greenhopper.web.rapid.sprint.SprintsResource$1.call(SprintsResource.java:75)
at com.atlassian.greenhopper.web.rapid.sprint.SprintsResource$1.call(SprintsResource.java:56)
at com.atlassian.greenhopper.web.util.RestCall.response(RestCall.java:48)
at com.atlassian.greenhopper.web.AbstractResource.response(AbstractResource.java:48)
at com.atlassian.greenhopper.web.rapid.sprint.SprintsResource.getAllSprintsForRapidView(SprintsResource.java:55)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)

Cause

This error is caused by invalid or corrupted indexes on JIRA. It is necessary to re-build them to fix this problem.

Resolution

  1. Shutdown your JIRA instance.
  2. Delete the content of the following folder:
    (info) This is a temporary directory and will be recreated upon JIRA restart.

    $JIRA_HOME/caches/indexes
    
  3. Restart your JIRA instance.
  4. Run the Re-index (Administration -> System -> Indexing). Please note that your instance will be unavailable while the re-index runs.

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.