Issues Become Resolved Silently

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

When putting an Issue through a Transition (including the Create Issue transition), the Issue becomes resolved, even though a Resolution was not selected.

Diagnosis

Typically, the Issues affected by this problem will all have the same Resolution.

Cause

This is normal program behaviour. The Resolution field is special, in that it is required when it appears on a screen, even though it's not been made required in the Field Configuration. If it appears on a screen, any actions that involve that screen will result in a Resolution being set.

Resolution

  • Locate the offending Transition
  • Identify the Screen used by this transition
  • Ensure the Resolution field does not appear on this screen
Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.