JIRA does not reflect changes to my Active Directory

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

  1. JIRA out of sync with Active Directory
  2. Recent changes to Active Directory do not appear in JIRA

Diagnosis

Use an LDAP browser (such as Softerra's LDAP Administrator) to review the consistency of your AD controllers. If the domain controller attached to your JIRA or Crowd has a different user list than the Global Domain Controller (GDC), you are having this issue.

Cause

This issue is caused by retrieving the directory listing from a machine other than the Global Domain Controller (GDC). While the GDC is the authoritative directory, other Domain Controller's (DCs) on the network will only synchronize directories periodically. This causes the appearance of an incomplete directory in JIRA.

Workaround

To work around this issue, increase the sync frequency of your Domain. This does introduce some additional network overhead.

Resolution

To resolve this issue, connect your JIRA or Crowd directly to the GDC

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.