JIRA email template variable not replaced in the email received

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Symptoms

The same problem could occur with JIRA Servicedesk emails as well.

 

The email from JIRA are received something like this : 

Status changed to Fixed with resolution {1}

It should be :

Status changed to Fixed with resolution Answered

 

The variables from the email template are not replaced by the actual values.

Cause

There is a post-function(might be coming from a plugin) in the workflow that is sending the email. This post-function is delaying the transition for so long that the email is sent before it is completely rendered.

Workaround

Remove the post-function.

Resolution

  • Check where the post-function is coming from and report a bug to the respective vendor.
Last modified on Mar 30, 2016

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