JIRA stops creating tickets from emails
Symptoms
JIRA was processing emails without any issues, and then stopped all of a sudden.
The following appears in the atlassian-jira.log
:
2013-03-19 18:44:14,238 QuartzWorker-0 ERROR ServiceRunner Handler-name [atlassian.mail.incoming.mailfetcherservice] Handler-name[10060]: Exception: Folder is not Open
java.lang.IllegalStateException: Folder is not Open
at com.sun.mail.pop3.POP3Folder.checkOpen(POP3Folder.java:547)
at com.sun.mail.pop3.POP3Folder.getProtocol(POP3Folder.java:577)
at com.sun.mail.pop3.POP3Message.loadHeaders(POP3Message.java:606)
at com.sun.mail.pop3.POP3Message.getHeader(POP3Message.java:364)
at com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl.getAndProcessMail(MailFetcherService.java:257)
at com.atlassian.jira.service.services.mail.MailFetcherService.runImpl(MailFetcherService.java:356)
at com.atlassian.jira.service.services.file.AbstractMessageHandlingService.run(AbstractMessageHandlingService.java:252)
at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)
at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:47)
at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
at com.atlassian.multitenant.quartz.MultiTenantThreadPool$MultiTenantRunnable.run(MultiTenantThreadPool.java:72)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
If you hit this issue on a mail server other than Exchange, please comment on this issue and let us know.
Cause
The POP/IMAP server is not allowing JIRA to open the mailbox. The actual root cause to this can vary. In every case of this issue we have seen, it has always been caused mail server issues outside of JIRA's control.
Resolution
Fix this on your mail server. The common fix we have seen is to create a new mailbox and use that.