Jira Calendar plugin results in stacktrace when hitting the I-cal export link
Symptoms
When pressing the link to export the Calendar to a I-cal compatible file the action will result in a stacktrace.
The following appears in the atlassian-jira.log
:
2011-08-15 10:26:59,573 TP-Processor11 ERROR [500ErrorPage.jsp] Exception caught in 500 page null
java.lang.NullPointerException
at com.atlassian.jira.ext.calendar.model.CalendarFactory.createICalendarFromSearch(CalendarFactory.java:75)
at com.atlassian.jira.ext.calendar.ICalendarServlet.service(ICalendarServlet.java:109)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
Cause
This is caused by the timezone in the JVM being incorrectly set. There is a bug raised for this under JCAL-186 .
Resolution
- Modify the Timezone, as per our Set the timezone for the Java environment documentation to be something different, for example
-Duser.timezone=America/Chicago
. - Restart the instance.
Last modified on Mar 30, 2016
Powered by Confluence and Scroll Viewport.