Jira Created Issue From E-mail Has No Description
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Problem
When creating issue by e-mail handler, issues that are created have no description.
The following errors can be seen in the logs:
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2015-05-25 15:57:37,842 QuartzScheduler_Worker-1 ERROR ServiceRunner hxztest [atlassian.jira.mail.MailThreadManagerImpl] Unable to parse incoming In-Reply-To header <JIRA.20509.1096924742000@Atlassian.JIRA>
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2015-05-25 00:23:02,756 QuartzScheduler_Worker-2 INFO "Mail Handler Name" [com.atlassian.mail.MailUtils] Exception getting the content type of message - probably not of type 'String': javax.mail.util.SharedByteArrayInputStream cannot be cast to java.lang.String
Cause
If the email encoding is as below, it explains why no content appears. This won't work with Atlassian default handler as the content is not in clear text.
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Content-Type: application/ms-tnef; name="winmail.dat"
Or
Content-Type: text/plain; charset="US-ASCII"
Resolution
Change the Email encoding to any clear text encoding.
You can handle this type of encoding Content-Type: application/ms-tnef; name="winmail.dat" with JEMh Plug in
Updated on April 8, 2025
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