Jira throws timeout errors on install or upgrade
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When installing or upgrading to JIRA Software, the following error may occur:
The call to the JIRA server did not complete within the timeout period. We are unsure of the result of this operation.
The following appears in the atlassian-jira.log
:
Caused by: java.lang.IllegalStateException: Can only register services while bundle is active or activating.
at org.apache.felix.framework.Felix.registerService(Felix.java:2817)
at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:251)
or:
/rest/plugins/1.0/com.pyxis.greenhopper.jira-key [atlassian.plugin.manager.DefaultPluginManager] There was an error loading the descriptor 'JIRA Agile Help' of plugin 'com.pyxis.greenhopper.jira'. Disabling.
java.lang.RuntimeException: Unable to enable web fragment
at com.atlassian.plugin.web.descriptors.AbstractWebFragmentModuleDescriptor.enabled(AbstractWebFragmentModuleDescriptor.java:133)
at com.atlassian.plugin.web.descriptors.DefaultWebItemModuleDescriptor.enabled(DefaultWebItemModuleDescriptor.java:72)
at com.atlassian.plugin.web.descriptors.DefaultAbstractWebFragmentModuleDescriptor.enabled(DefaultAbstractWebFragmentModuleDescriptor.java:34)
...
Caused by: java.lang.IllegalStateException: Cannot create object because the plugin container is unavailable for bundle 'com.pyxis.greenhopper.jira'
at com.atlassian.plugin.osgi.factory.OsgiPluginInstalledHelper.getRequiredContainerAccessor(OsgiPluginInstalledHelper.java:219)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.autowire(OsgiPlugin.java:372)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.autowire(OsgiPlugin.java:362)
Cause
There are two known causes for this issue:
- The inconsistency of OSGI plugin caches triggered from inappropriate shutdown of Tomcat.
- The Tomcat user not have the correct permissions to access the directory.
Resolution
Option #1
- Stop JIRA Software;
Remove the below directories, that hold plug-in caches:
<JIRA_HOME>/plugins/.osgi-plugins/ <JIRA_HOME>/plugins/.bundled-plugins/
Those directories will be recreated upon JIRA Software's next startup.
- Ensure that the user which runs JIRA Software has the correct permissions on these directories (recursively);
- Start JIRA Software;
Option #2
If the above solution does not work, then you're probably facing a timeout problem. To resolve that, you'll have to increase the timeout JIRA Software imposes in the plugin loading process.
- Stop the application JIRA Software;
Following these instructions, add the below argument to JIRA Software's startup parameters:
-Datlassian.plugins.enable.wait=300
- Start the application JIRA Software.