Merge Duplicate LDAP User Accounts

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Duplicate user error messages can occur in JIRA when a new LDAP user directory is added to JIRA, if an existing username is edited to a username that already exists in JIRA, or when switching to a new database or LDAP account while still wanting to keep the old issues tied to the new user.

Symptoms

  1. Have duplicate users or user directories with different names

  2. Try to change the name of one of the duplicates

  3. Throws error that a user already exists with this name

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Cause

All associations of comments and other items in JIRA are based off username. When you try to rename a user to that Unique Identifier it throws this error.

Workaround

    1. Login as internal JIRA admin user.

    2. Disable the old AD User Directory.

    3. Rename all users to your current AD naming structure.

    4. Turn your old AD User Directory back on and make sure it's the new AD naming structure is on top of the User Directories list.

This fixes the issue because of the way JIRA reads User Directories. JIRA starts from the top of User Directory and pulls out all users it finds. Once it finds a user JIRA no longer looks or tries to pull out user information for that particular username.

Updated on April 8, 2025

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