JIRA Documentation

JIRA 6.3
JIRA 6.0 Documentation
JIRA 5.2 Documentation
JIRA 5.1 Documentation
More...
 

 

Search the Knowledge Base and Documentation Spaces

You're visiting the JIRA Knowledge Base. Visit the JIRA Knowledge Base Home for an overview.

Skip to end of metadata
Go to start of metadata

Symptoms

The 'Plugins' link (Administration -> System -> Plugins) is missing after upgrading to 4.3 or later version.

Cause

The cause is a known bug that has been fixed in JIRA 5.0.5,  JRA-24218 - UPM doesn't get enabled on upgrade to 4.3 Resolved

JIRA 4.3+ bundles the Universal Plugin Manager and uses it to manage all bundled and extension plugins. Normally, we may see the above scenario when one has installed and disabled UPM Plugin in the old JIRA instance (before 4.3) and then upgraded to 4.3 or a later version.

Workaround

Icon

Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.

  1. Stop JIRA.
  2. Run the following SQL against the JIRA database to re-enable the plugin:

  3. Start JIRA and test to see if the UPM is accessible.

If there are any problems with the SQL update, please rollback JIRA to the backup immediately so as to avoid any possible data integrity issues.

Related Content

Help us improve!
Is this article helpful?
Is the content complete?
Is it well written?

3 Comments

  1. "Reboot the JIRA instance..." Is it necessary to reboot the machine?

    Reboot is not the same as restart the service. If you mean to restart the JIRA instance, then perhaps you should say that. Reboot means machine (or VM) by every definition I've ever seen. This is not a subtle difference. 

    http://www.thefreedictionary.com/reboot

    http://www.answers.com/topic/reboot

     

    1. Hey Richard, I believe what we were originally trying to convey is to restart the JIRA instance rather than the server it is running on. I have updated the KB accordingly. (smile)

  2. Great! Thanks for the clarification!