New issues created in Jira when re-index is performed
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
New issues are seemingly created when a project/instance re-index is performed. These new issues have an old 'Created date'. These type of issues are easier to notice if a team uses a specific queue or filter (eg. unassigned issues, issues in Open status, etc) to view their issues on a daily basis.
Environment
Any version of Jira
Diagnosis
New issues appear in Jira with an old 'Created date'. They also have old issue keys (ie. If the latest issue key is PROJ-100, these issues have old issue keys such as PROJ-55)
When checking the IDs/dates of these issues in the DB, their sequence is normal, meaning that their date/IDs are also using old values as opposed to having a completely latest IDs (similar to issue key situation above)
These issues appeared after Jira or a project re-index has been performed
There might be multiple of the same or similar type of issues appearing
Cause
New issues have actually not been created. What likely happened is that there was an incident during the creation of these issues which led to these issues failing to be re-indexed.
Issues were actually created in the past but wasn't re-index, so nobody actually noticed that these issues exist in the instance as they are not being returned in any search results
If there were problems during creation, the original reporter might have attempted to create the same issue multiple times, leading to an actual creation of multiple same/similar issues which wasn't re-indexed
Upon a recent instance/project re-index, these issues are now successfully re-indexed and being returned in search results
This results in these old issues suddenly appearing in any existing queues/filters which your team uses
Solution
There is no solution to this. You can check and confirm whether there was an incident during the original issue creation. However, the issues are all already successfully created and are legitimate issues. You can proceed to close/delete these issue if there aren't any need for them.
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