Password Reset E-mail Not Sending the Correct Message in Portuguese

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Symptoms

When reseting the password using the Brazilian Portuguese language pack, users receive an email with the following message:


Você (ou outra pessoa) solicitou uma nova senha.

---------------------------------------------------------------------

Sua senha foi alterada para: {0}

Cause

The problem is with the language_pt_BR.jar file.

In the older JIRA versions, the password was sent in the body of the email when the 'reset password' option was used. In JIRA 4.1.2, only the reset password link is sent in the message. The language_pt_BR.jar was not updated to reflect the change.

Resolution

  1. Change the following line in the <JIRA_install>/atlassian-jira/WEB-INF/lib/language_pt_BR/com/atlassian/jira/web/action/JiraWebActionSupport_pt_BR.properties enclosed in this jar file:
    
    template.user.forgotpassword.passwordchanged = Sua senha foi alterada para: {0}
    
    to
    
    template.user.forgotpassword.passwordchanged = Clicando no link abaixo, sua senha pode ser alterada.
    
  2. Re-zip or re-jar the file.
  3. Restart JIRA.

Last modified on Feb 26, 2016

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