Resolution date set on unresolved issues after a CSV import

Symptoms

If you import issues (using CSV import) and map with "Unresolved" resolution field, the issues will have a resolution date set.

Cause

After mapping the resolution field, Jira will recognize the resolution field as Resolved, even if you put "Unresolved" in the resolution as part of the import process. For more information, read Defining 'Resolution' Field Values article as quoted:

 Any issue that has the Resolution field set is treated by JIRA as "resolved". The Issue Navigator displays Unresolved when no resolution is set for an issue. So adding a resolution named Unresolved and setting it in an issue will mean that the issue is seen by JIRA as resolved. This will lead to confusion and is not recommended. 

Jira will recognize the resolution date as the current date and time and displays it.

Resolution

Use Modifying Multiple ('Bulk') Issues to correct. You could also follow the workaround in How to clear the resolution field when the issue is reopened.

Last modified on May 15, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.