Some users are unable re-order Jira issues on an Agile board
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Some users are unable to re-order/rank issues on an Agile board. When they try to drag and drop issues in the backlog, the issue goes back to its original position, and an error/warning pops-up in the UI.
This KB article lists all the known root causes for this type of issue.
Environment
Jira Server / Data Center on any version from 7.0.0.
Diagnosis
Check the message displayed in the UI when you try to re-order issue, as it will show you the reason why it is not possible.
- If you get the error Ranking is disabled, as the Filter Query for this board is not ordered by ascending Rank, then you are impacted by Root Cause 1
- If you get the error You cannot perform this operation because you do not have "Schedule" Permission, then you are impacted by Root Cause 2
- If you get the error You do not have permission to edit this issue, then you are impacted by Root Cause 3
- If you get the error JIRA Software cannot execute the rank operation at this time. Other users may be ranking the issues that you are trying to rank. Please try again later, then you are impacted by Root Cause 4
Cause
Root Cause 1
Ranking is not enabled for the board where you are trying to re-order issues, which can be confirmed by going to the board configuration page located at Board > Configure > General
As explained in the documentation Enable ranking, ranking can only be enabled for a given board if the filter associated to this board contains the statement "ORDER BY Rank ASC".
Root Cause 2
For a user to be able to re-order issues on a board, this user needs to be granted the Schedule Issues permission for the project the issue belongs to. If this user is not granted such permission, this user won't be able to re-order this issue.
Root Cause 3
For a user to be able to re-order issues on a board, this user needs to be granted the Edit Issues permission for the project the issue belongs to. If this user is not granted such permission, this user won't be able to re-order this issue.
Root Cause 4
The ranking of issues on a board can occur when the rebalancing operation (required to rank issues) is taking too long to complete or fails to complete. There can be various reasons that prevents the rebalancing to complete successfully, which are addressed in the KB articles linked in the section Solution for Root Cause 4
Solution
Solution for Root Cause 1
Follow the instructions from the documentation Enable ranking, to enable ranking for the board where the user was unable to re-order issues. The steps are listed below for your reference:
Go to the desired board, then click Board > Configure.
Note that only the administrator of a board (or a person with the 'Jira Administrators' global permission) can configure a board.Click the Add Rank button. This will append the following to your filter's query:
ORDER BY Rank ASC
Solution for Root Cause 2
Grant the impacted users with the Schedule Issues permission in the project that the Jira issue belongs to. For more information on how to configure project permissions, please refer to the documentation Manage Project Permissions.
Solution for Root Cause 3
Grant the impacted users with the Edit Issues permission in the project that the Jira issue belongs to. For more information on how to configure project permissions, please refer to the documentation Manage Project Permissions.
Solution for Root Cause 4
Since there can be various reasons why the rebalancing process has not completed as it should, we recommend to refer to the KB articles and known bug listed below:
- Relevant KB articles:
- Relevant bugs: