Unable To Zoom On a Two-Dimensional Filter
Symptoms
Clicking in a cell (on the number) in a two-dimensional filter leads to
There is no current active search.
Diagnosis
- running filter directly will return correct result
- Clicking on the two-dimensional filter as described above, shows some characters scrambled, thus pointing to an encoding issue.
Cause
Encoding is not properly configured.
Resolution
CAUTION: The following information (database, ports, etc) should vary according to your specific configuration
- Ensure the Systems Encoding under Administration --> System Info --> System Encoding is it UTF-8
- Check database encoding (MySQL example follows):
Log into native db tool and make sure the following returns utf8 for both Server and Db:
use <your jira database>; status;
Check JIRA's dbconfig.xml file for the following:
<url>jdbc:mysql://localhost:3306/jiradb?useUnicode=true&characterEncoding=utf8&sessionVariables=storage_engine=InnoDB</url>
If user's connection is using a Jakarta Connector (mod_jk) to access JIRA, then also check the following in the Tomcat's server.xml file:
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" URIEncoding="UTF-8"/>
General Guidelines
In general, the above configuration should vary according to the network and the way JIRA has been installed. But checking the above is a good start.