Unable to Create Issue Due to Data Corruption

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Users are unable to create issues. Logs contain:

Caused by: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:Issue][created,2007-12-14 08:12:41.979][summary,test issue create ][workflowId,43401][timeoriginalestimate,null][type,1][timespent,null][environment,null][status,1][updated,2007-12-14 08:12:41.979][id,43401][timeestimate,null][key,MAINTENANCE-50][description,test issue create ][duedate,null][reporter,admin][project,10016][security,null][votes,0][assignee,gowso01.dimdim][priority,3] (SQL Exception while executing the following:INSERT INTO jiraissue (ID, pkey, PROJECT, REPORTER, ASSIGNEE, issuetype, SUMMARY, DESCRIPTION, ENVIRONMENT, PRIORITY, RESOLUTION, issuestatus, CREATED, UPDATED, DUEDATE, VOTES, TIMEORIGINALESTIMATE, TIMEESTIMATE, TIMESPENT, WORKFLOW_ID, SECURITY, FIXFOR, COMPONENT) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Duplicate entry '43401' for key 1))

Cause

There is a workflow entry with this ID already included in the database.

To confirm this is the root cause, run the query below in the database and a row should be returned:

select ID from JIRAWORKFLOWS WHERE ID=ID_mentioned_on_logs

 

Resolution

This error can be resolved by running the Database Integrity Checker.

 

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.