Unable to Log Work

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

The "Log Work Done" option is not available from the user interface. In JIRA 4.1 and later, this is usually listed in the More Actions menu.

Cause

This is due to one of several JIRA configurations.

Resolution

  1. Ensure the user has the "Work on Issues" permission in the permission scheme. It's possible that the user is not in the group, or not in the project role.
  2. Ensure that time tracking is enabled globally.
  3. Check whether the issue is 'Closed', or the workflow has put the issue in a state that is uneditable.
  4. Ensure that the Time Tracking field is visible (not hidden) on the Field Configuration.

    Note that this last procedure will allow editing of closed issues. If you wish to edit only this one issue, simply reopen the issue, add time tracking, and re-close.

    1. Choose the issue that is being affected by this problem (e.g. issues with Closed status).
    2. Navigate to Administration >> Global Settings >> Workflows and check for the Active workflow that the issue is using.
    3. Create a draft workflow since the current workflow is in an Active state.
    4. Click on View Properties for the affected issue status.
    5. Delete jira.issue.editable if it's set to false.
    6. Add a new property with the same property key (jira.issue.editable) but set to true.
    7. Publish this workflow draft.

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.