Unable to Log Work
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The "Log Work Done" option is not available from the user interface. In JIRA 4.1 and later, this is usually listed in the More Actions
menu.
Cause
This is due to one of several JIRA configurations.
Resolution
- Ensure the user has the "Work on Issues" permission in the permission scheme. It's possible that the user is not in the group, or not in the project role.
- Ensure that time tracking is enabled globally.
- Check whether the issue is 'Closed', or the workflow has put the issue in a state that is uneditable.
Ensure that the
Time Tracking
field is visible (nothidden
) on the Field Configuration.Note that this last procedure will allow editing of closed issues. If you wish to edit only this one issue, simply reopen the issue, add time tracking, and re-close.
- Choose the issue that is being affected by this problem (e.g. issues with Closed status).
- Navigate to
Administration >> Global Settings >> Workflows
and check for the Active workflow that the issue is using. - Create a draft workflow since the current workflow is in an
Active state
. - Click on View Properties for the affected issue status.
- Delete jira.issue.editable if it's set to
false
. - Add a new property with the same property key (jira.issue.editable) but set to
true
. - Publish this workflow draft.