Unable to Login from Internet Explorer Running Behind IIS

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Users are unable to login to JIRA using IE when proxied behind IIS. The user is presented with a dialog box, asking for username and password when visiting JIRA and authentication fails in spite of valid credentials. In contrast, Firefox works fine.

Cause

Internet Explorer's user security level set to 'Automatic logon only in Intranet zone' for JIRA's security zone.

Resolution

Set the Internet Explorer user security level to 'Anonymous logon' for JIRA's security zone to stop IE from displaying the dialog box prompting user credentials:

 

  1. Go to Internet Options and select the Security tab.
  2. Select the security zone that the JIRA server is in, and press the "Custom level..." button.
  3. Scroll right down to the bottom to the User Authentication section. Select 'Anonymous Login', then press the OK button, then the next OK button.
  4. Restart Internet Explorer.

    Ensure that basic authentication is not enabled on the /jira directory in IIS. See this Unable to Log into JIRA when Proxied Behind IIS for details.

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.