Unable to upgrade Jira Service Management after upgrading Jira Software

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Jira Software using the installer, the button to upgrade Jira Service Management is not available in the ⚙️ → Applications → Versions & licenses page. You may see a warning that Jira Service Management is licensed but not installed.

Environment

8.16.x

Cause

The issue has not been reproduced but may result from the upgrade method used. Often this appears to be the result of a failed upgrade task. Please feel free to create a Support Zip and send it to Atlassian Support and we can investigate the upgrade tasks for you.

Solution

Use the Upload application feature to install the appropriate .obr file from the JSM Version history page. To find the right version, check out the Jira applications compatibility matrix for your version.

Updated on April 8, 2025

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