Unexpected issues added to a Sprint
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When working with Sprints, it might happen that you notice unexpected behaviours, (i.e an issue which users don't realise adding to a Sprint) appearing in the Sprint reports.
This article talks about one such scenarios where this behaviour can happen, and how to identify them.
Environment
Jira Software Server / Data Center 8.0.0 and any higher version.
Cause
A Sprint was renamed and some issues were previously added to the same Sprint when it had a different name.
For example, if a Sprint gets renamed from Sprint A to Sprint B, the issues which belonged to Sprint A will show up in Sprint B.
Diagnosis
To verify this cause, check the details as illustrated using an example issue PIZ-1 below.
- Sprint field on the issue shows Sprint B
- Issue shows up under Sprint B
- However, the history tab does not show that the issue was added to Sprint B. It shows that the issue was added to Sprint A which has Sprint ID 5.
Now, verify the Sprint ID of Sprint B from the database using below SQL.
select "ID", "NAME" from "AO_60DB71_SPRINT" where "NAME" like '%Sprint B%';
Looking at the output below, it can be seen that Sprint ID for Sprint B is also 5
Result
Since the Sprint ID for both Sprint A and Sprint B is 5, it can be confirmed that the Sprint was renamed and the issue PIZ-1 was added to this Sprint when it was named Sprint A as seen in the history tab of the issue.
This is expected behaviour.