Symptoms
When viewing the JIRA Service Desk login page, the 'Forgotten your password?' link, as below, does not appear:
Diagnosis
An outgoing mail handler has not been configured.
Cause
As the outgoing mail handler has not been configured, the 'Forgotten your password?' link will not appear.
Resolution
Setup the mail handler as per Configuring JIRA's SMTP Mail Server to Send Notifications.
Help us improve!