Symptoms
After changing the URL of the Confluence Application Link, the knowledge base links on JIRA Service Desk still points to the old URL. We're tracking this a bug on - JSD-641Getting issue details... STATUS .
Diagnosis
Simply run the following SQL query in JIRA's database to verify which is the URL in use by JSD:
SELECT * FROM "AO_54307E_CONFLUENCEKB";
Resolution
- Always backup JIRA before modifying its database.
- Stop JIRA;
- Update the
AO_54307E_CONFLUENCEKB
table, and update the application link URL. - Restart JIRA;
For example, if updating the URL from HTTP to HTTPS, the following can be used:
update "AO_54307E_CONFLUENCEKB" set "APPLINK_URL" = replace ("APPLINK_URL", 'http', 'https'), "SPACE_URL" = REPLACE ("SPACE_URL", 'http', 'https');
This was created using PostgreSQL - if you're using a different DBMS you may need to update the query accordingly.
Help us improve!