FishEye 2.4 Upgrade Guide

Below are some important notes on upgrading to FishEye 2.4. For details of the new features and improvements in this release, please read the FishEye 2.4 Release Notes.

On this page:

Upgrade Notes

  • FishEye 2.4:
    • If you are using a Mercurial or Git repository with FishEye, it will be automatically re-indexed when you upgrade to FishEye 2.4. This is because we have upgraded the database schema for these SCMs.
    • Lines of code data will not display for Git and Mercurial repositories in this release. This affects features like charts. Please see this FAQ for more information: Cannot View Lines of Code Information in FishEye.
  • FishEye 2.4.1:
    • If you use FishEye/Crucible with Perforce and previously upgraded to FishEye/Crucible 2.4.0, you must reindex all of your Perforce repositories after upgrading to FishEye/Crucible 2.4.1. Note, FishEye/Crucible will not automatically reindex your Perforce repositories, you will need to start the reindex manually.
  • FishEye 2.4.2:
    • If you are using a ClearCase repository with FishEye, it will be automatically re-indexed when you upgrade to FishEye 2.4.2. This is because we have upgraded the database schema for this SCM.

Upgrade Procedure

Upgrade a test environment first

As always, please test your upgrades in your test environment before rolling into production.

If you are already running a version of FishEye, please follow these instructions on FishEye upgrade guide.

Checking for Known Issues and Troubleshooting the FishEye Upgrade

If something is not working correctly after you have completed the steps above to upgrade your FishEye installation, please check for known FishEye issues and try troubleshooting your upgrade as described below:

  • Check for known issues. Sometimes we find out about a problem with the latest version of FishEye after we have released the software. In such cases we publish information about the known issues in the FishEye Knowledge Base. Please check the FishEye 2.4 Known Issues in the FishEye Knowledge Base and follow the instructions to apply any necessary patches if necessary.
  • Did you encounter a problem during the FishEye upgrade? Please refer to the guide to troubleshooting upgrades in the FishEye Knowledge Base.
  • If you encounter a problem during the upgrade and cannot solve it, please create a support ticket and one of our support engineers will help you.

RELATED TOPICS

FishEye 2.4 Release Notes

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport