Fisheye and Crucible Security Advisory 2018-01-31

Fisheye and Crucible - Remote code execution through OGNL double evaluation - CVE-2017-16861

Note: As of September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.

Summary

CVE-2017-16861 - Remote code execution through OGNL double evaluation.

Advisory Release Date

 10 AM PDT (Pacific Time, -8 hours)

Products Fisheye and Crucible

Affected Versions

  • version < 4.4.5
  • 4.5.0
  • 4.5.1

Fixed Versions

  • 4.4.5
  • 4.5.2
CVE ID CVE-2017-16861


Summary of Vulnerability

This advisory discloses a critical severity security vulnerability which affects Fisheye and Crucible. All versions of Fisheye and Crucible before 4.4.5 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.2 (the fixed version for 4.5.x) are affected by this vulnerability. 


Customers who have upgraded their Fisheye and Crucible installations to version 4.4.5 or 4.5.2 are not affected.

Customers who have downloaded and installed Fisheye or Crucible less than version 4.4.5 (the fixed version for 4.4.x)

Customers who have downloaded and installed Fisheye or Crucible >= 4.5.0 less than version 4.5.2 (the fixed version for 4.5.x)


Please upgrade your Fisheye and Crucible installations immediately to fix this vulnerability

Remote code execution through OGNL double evaluation (CVE-2017-16861)

Severity

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is our assessment and you should evaluate its applicability to your own IT environment.

Description

It was possible for double OGNL evaluation in certain redirect action and in WebWork URL and Anchor tags in JSP files to occur. An attacker who can access the web interface of Fisheye or Crucible or who hosts a website that a user who can access the web interface of Fisheye or Crucible visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Fisheye or Crucible.

All versions of Fisheye and Crucible before 4.4.5 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.2 (the fixed version for 4.5.x) are affected by this vulnerability. 

This issue can be tracked for Fisheye at:   https://jira.atlassian.com/browse/FE-6991.

This issue can be tracked for Crucible at  https://jira.atlassian.com/browse/CRUC-8156 .

Mitigation

This issue cannot be mitigated.

Fix

We have taken the following steps to address this issue:

  1. Released Fisheye version 4.5.2 that contains a fix for this issue.
  2. Released Crucible version 4.5.2 that contains a fix for this issue.
  3. Released Fisheye version 4.4.5 that contains a fix for this issue.
  4. Released Crucible version 4.4.5 that contains a fix for this issue.

What You Need to Do

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Fisheye, see the release notes. You can download the latest version of Fisheye from the download centre. For a full description of the latest version of Crucible, see the release notes. You can download the latest version of Crucible from the download centre.


Upgrade Fisheye and Crucible to version 4.5.2 or higher.

If you are running Fisheye or Crucible 4.4.x and cannot upgrade to 4.5.2 then upgrade to version 4.4.5.


Support

If you did not receive an email for this advisory and you wish to receive such emails in the future go to https://my.atlassian.com/email and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/.

References

Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for Jira and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

Severity Levels for security issues Atlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
End of Life Policy  Our end of life policy varies for different products. Please refer to our EOL Policy for details. 

Last modified on Jan 9, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.