Upgrading from FishEye 2.7 with existing ClearCase Repositories

ClearCase Repositories

FishEye 2.8 no longer supports ClearCase repositories. Please refer to the End of Support Announcement for IBM ClearCase.

If you have any ClearCase repositories present in your FishEye instance, FishEye 2.8 will log a warning and will not start. The intention behind this rather draconian behavior is to give you the opportunity to backup and update your instance before FishEye performs the upgrade operations to convert your indexes and database into a 2.8 compatible format.

You can force FIshEye to start with clearcase repositories disabled by setting the fisheye.clearcase.disable system property to true.  Please see the documentation on setting up fisheye environment variables for more information.

For example, you can force startup by setting your FISHEYE_OPTS environment variable to

-Dfisheye.clearcase.disable=true

ie.:

$ export FISHEYE_OPTS="${FISHEYE_OPTS} -Dfisheye.clearcase.disable=true"

On Windows Server 2008 or Windows 7, you can configure this as follows:

  1. Open the Start menu, right-click on "Computer" and select Properties
  2. Click on "Advanced System Settings" on the left of the dialog
  3. Click the "Environment Variables" button at the bottom of the Advanced tab
  4. Add a FISHEYE_OPTS environment variable to the "System variables" section

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport