Cannot edit or create reviews

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Symptoms

When creating or editing reviews, the review dialog never opens as per screenshot below:

Cause

This issue is often experienced by users who have proxied Crucible behind an Apache server with an incorrect configuration.

Case in point, the following configuration was used to set up Apache redirects from HTTP to HTTPS:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

<IfModule proxy_ajp_module>
<Proxy *>
        Order deny,allow
        Allow from all
</Proxy>

ProxyRequests       Off
ProxyPreserveHost   On
ProxyPass           /fisheye     ajp://127.0.0.1:8010/fisheye
</IfModule>

Resolution

Make sure that your proxy settings under Administration -> Server Settings -> Web Server match the public URL of your Crucible instance.

In the following example, Crucible is accessed via https://erdinger.sydney.atlassian.com/fisheye, thus ensure the following values are correct:

Proxy Scheme

https

Proxy Host

erdinger.sydney.atlassian.com

Proxy Port

443

Site URL

https://erdinger.sydney.atlassian.com/fisheye

 

Last modified on Nov 29, 2016

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