Cannot edit or create reviews

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When creating or editing reviews, the review dialog never opens as per screenshot below:

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Cause

This issue is often experienced by users who have proxied Crucible behind an Apache server with an incorrect configuration.

Case in point, the following configuration was used to set up Apache redirects from HTTP to HTTPS:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} <IfModule proxy_ajp_module> <Proxy *> Order deny,allow Allow from all </Proxy> ProxyRequests Off ProxyPreserveHost On ProxyPass /fisheye ajp://127.0.0.1:8010/fisheye </IfModule>

Resolution

Make sure that your proxy settings under Administration -> Server Settings -> Web Server match the public URL of your Crucible instance.

In the following example, Crucible is accessed via https://erdinger.sydney.atlassian.com/fisheye, thus ensure the following values are correct:

Proxy Scheme

https

Proxy Host

erdinger.sydney.atlassian.com

Proxy Port

443

Site URL

https://erdinger.sydney.atlassian.com/fisheye

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Updated on April 8, 2025

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