ERRORS "at com.cenqua.fisheye.user.UserLogin.<init>" after migrating your users to LDAP User Management

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Errors like the following are found in the Fisheye/Crucible debug logs after migrating users to LDAP User Management:
 

2012-04-16 10:35:29,822 ERROR [btpool0-23225 ] org.mortbay.log org.mortbay.log.Slf4jLog-warn - /rest-service-fe/changeset-v1/listChangesets/
java.lang.NullPointerException
        at com.cenqua.fisheye.user.UserLogin.<init>(UserLogin.java:16)
        at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLoginImpl(DefaultUserManager.java:784)
        at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLogin(DefaultUserManager.java:753)
        at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLogin(DefaultUserManager.java:761)
        ...

Cause

This is a LDAP integration issue. Specifically, the errors indicates a problem with Case Sensitive Usernames.

Resolution

Use the option to force imported usernames to be lowercase and subsequently re-sync the users:

To force lowercase usernames, carry out the following steps:

  1. Log into Fisheye's Admin Interface.
  2. Under Authentication settings, the option Force Lowercase Username can be toggled on and off.
  3. With this setting switched On, when new users are added to Fisheye from an external authentication source, all usernames will be converted to lowercase.

 

 

 

 

 

 

Last modified on Jul 31, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.