Fisheye Crucible Failed 'Copy User on Login' Delegated LDAP Issue : Exceeded Maximum Login Attempts for a new User

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

'Copy User on Login' attempt from a Delegated LDAP directory fails for a user. Logs show "exceeded max login attempts" for the user.


Environment

4.8.10
.

Diagnosis

  • Copy user on login attempts fails for a particular user from Delegated LDAP Directory. Below DEBUG logs are logged.

    2023-09-18 10:53:56,018 DEBUG [qtp478489615-145209 ] fisheye DefaultUserManager-loginWithSanitizedUserName - Login: exceeded max login attempts for "<<username>>"
  • The user does not get any CAPTCHA challenge during the login attempt.
  • The username is not listed in the user list (Admin → User Settings → Users) and hence there is no option to clear the CAPTCHA for the user.
  • The user was previously part of the Internal Directory (or some other directory) and has been deleted since.

Cause

  • This issue arises when a user, initially part of the internal directory, has been deleted while CAPTCHA was still enabled for that user.
  • Fisheye has a relatively older version of Crowd plugin (Atlassian Embedded Crowd - Administration Plugin) and hence the user CAPTCHA status is still maintained even after deletion.
  • Subsequently, if the same user attempts to log in via "Delegated LDAP" with "Copy user on login" it fails due to 'exceeded max login attempts'.
  • As the user account is deleted and no longer appears in the User List, it becomes impossible to clear the CAPTCHA for this user.

Solution

  • To get around this issue you can manually create the user again in Fisheye Crucible and then reset their CAPTCHA.




  • Alternatively, you can disable the CAPTCHA check temporarily in your Fisheye Crucible instance and then ask the user to log in with the correct password. Once the user is able to log in from the Delegated LDAP and successfully added to the User List you can go ahead and re-enable the CAPTCHA back.


Last modified on Dec 2, 2023

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