JDBCExceptionReporter - JDBC ERROR has been closed() -- you can no longer use it

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

When trying to index (incremental or intial indexing) Fisheye starts logging the following ERROR

2012-07-20 13:24:56,176 ERROR [InitialPinger1 <REPOSITORY>] util.JDBCExceptionReporter JDBCExceptionReporter-logExceptions - com.mchange.v2.c3p0.PoolBackedDataSource@84e4ac51 [ connectionPoolDataSource -> com.mchange.v2.c3p0.WrapperConnectionPoolDataSource@601f8392 [ acquireIncrement -> 3, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, debugUnreturnedConnectionStackTraces -> false, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1l3ws9y8ozq281gb5sw8g|1118efc0, idleConnectionTestPeriod -> 0, initialPoolSize -> 5, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 1800, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 20, maxStatements -> 50, maxStatementsPerConnection -> 0, minPoolSize -> 5, nestedDataSource -> com.mchange.v2.c3p0.DriverManagerDataSource@7ea1959e [ description -> null, driverClass -> null, factoryClassLocation -> null, identityToken -> 1l3ws9y8ozq281gb5sw8g|78189538, jdbcUrl -> jdbc:hsqldb:file:/opt/atlassian/fisheye/var/data/crudb/crucible, properties -> {user=******, password=******, autocommit=false} ], preferredTestQuery -> null, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false; userOverrides: {} ], dataSourceName -> null, factoryClassLocation -> null, identityToken -> 1l3ws9y8ozq281gb5sw8g|3630fb71, numHelperThreads -> 3 ] has been closed() -- you can no longer use it.

Cause

This is caused probably because your embedded FeCru Database is corrupted.

Resolution

We have already seen that kind of issue in the past and moving that customer's HSQL to an external DB solved their problem.

We support the following DBs:

  • MySQL
  • Oracle
  • PostgreSQL
  • SQL Server

Please refer to the following doc to learn how to migrate your current HSQL to an external DB: Migrating to an external database

Last modified on Jul 31, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.