Plugin manager won't update

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When clicking on Update now! (see attachment below), a panel is displayed Preparing to update the UPM but an error message appear in the background saying An unexpected error occurred. Please refer to the logs for more information. So the panel keeps spinning and never goes away.

(Auto-migrated image: description temporarily unavailable)

Also at Plugin Manager if you select option Show System Plugins, scroll down to the Atlassian Universal Plugin Manager Plugin and click on the Update button, the following error will appear:

1 "The system attempted to connect to http://your-fisheye-address:8060/dev/rest/plugins/1.0/pending/178f5501-7aa7-418e-b8ab-4e6818ff2525 to retrieve the status of your operation, but failed. This may indicate a problem with the base URL configuration of your instance. Try refreshing the page to see if the operation completed, and see the UPM documentation for more details about this error."

Cause

This happens when the SITE URL is NOT configured.

Resolution

  • Go to Fisheye Administration > Server > Web Sever > Edit Settings.

  • Set the SITE URL to use the fully-qualified name of your Fisheye/Crucible instance.

Updated on April 8, 2025

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