Users don't have Permission to Crucible after Upgrading License (Increasing Number of Licensed User)

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Symptoms

  • Fisheye/Crucible is using External Authentication with  LDAP or Crowd Authentication and synchronisation enabled and the Fisheye version is < 4.0.
  • Original license had more users for Fisheye than Crucible and the user base was synchronised with LDAP, because Fisheye has a higher user limit than Crucible, when users were imported it exceeded the Crucible license limit and users do not have permission to login.
  • The following error is reported in the logs:
...
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,311 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username101 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,351 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username102 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,391 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username103 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,439 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username104 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,480 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username105 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,519 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username106 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
fisheye-debug.log.2009-05-25:2009-05-25 21:41:10,559 INFO  [AuthSynchroniser] fisheye.app UserManager-addUserImpl - Newly-added user username107 could not be made a Crucible user:You have reached your maximum of 100 Crucible users.
...

Thus you purchase a new license that matches the Fisheye user count and install the new license in your Administration > Sys Info\Support > Edit License.

However your users still do not have permission to use crucible, even if you click on Re-sync.

Cause

Permission to use crucible is set automatically when a user is created. Doing another synchronise (once you have updated your license) will not change this as synchronise only deletes users that no longer exist in Crowd/LDAP repositories from Fisheye, or creates users for those that exist in Crowd/LDAP but have not yet been added to Fisheye. It will not modify users that already exist in both Fisheye and your Crowd/LDAP server.

Resolution

Manually editing users to grant access

You can enable permission for a user to use Crucible manually by going to:

  1. Go to Administration > Users
  2. Click on the user to be edited.
  3. Ensure the field Active Crucible User is checked.

However, this can be time consuming as Crucible doesn't have bulk user edit. There is a feature request at FE-644 (Your comments and vote on that issue are very much appreciated).

Deleting existing users and re-adding them.

The other workaround would be to delete all your users and re-add them.

If you are using Crowd:

  1. In Crowd create temp application (lets call it fisheye_tmp) and for this application create a directory with only one user (lets call this user "randomUsername").
  2. Edit your Administration > Security > Crowd Authentication to point to your fisheye_tmp application
  3. Click re-sync, this should delete your users and add the one user (randomUsername) from the fisheye_tmp directory.
  4. Edit your Administration > Security > Crowd Authentication to point back to your proper Fisheye application in Crowd with the users.
  5. Click resync, this should delete the randomUsername and add your users back and enable them for Crucible.

If you are using LDAP:

  1. Edit your Administration > Security > LDAP Authentication and change your user filter so that it will only point to one user.
  2. Click re-sync, this should delete your users except for the one user (that the user filter matches).
  3. Edit your Administration > Security > LDAP Authentication to set the configuration back to how it was so that it will match the users that you want to have access to Fisheye.
  4. Click resync, this should add your remaining users back and enable them for Crucible.

If you choose to delete users, please note that their "watches" and preferences will be lost, your users can set these preferences and watches again after the resync.

If you do not want the watches and preferences to be lost, then you will have to manually add the permission for Crucible as mentioned earlier.

Last modified on Nov 2, 2018

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