Admin received alerts email "failed to start (exit status 0) – /etc/init.d/user-sync: Starting user-sync... ok"

This Knowledge Base article was written specifically for the Atlassian Server platform. Due to the Restricted functions in Atlassian Cloud apps, the contents of this article cannot be applied to Atlassian Cloud applications.

Problem

After a server upgrade to v2.0 build 1.4.1, admin started to receive the following alerts emails:

Action: alert
Desc: failed to start (exit status 0) – /etc/init.d/user-sync: Starting user-sync... ok
 
Event: Execution failed
Service: java

Cause

Starting from server v1.2 build 1.2.8, user-sync service is no longer used but the file exists on the server v2.0 build 1.4.1 hence admin received the misleading email. Note: This however does not imposed any harm to the server.

Resolution

Run the following command to disable alerts for user-sync:

sudo dont-blame-hipchat
service monit start
monit summary
monit stop user-sync || true
rm -f /etc/monit.d/user-sync.monitrc
/usr/sbin/update-rc.d -f user-sync remove || true
rm -f /etc/init.d/user-sync
dpkg --purge hc-user-sync

Internally, we're working on a script to clean this up in the upcoming HipChat Server release.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport