Admin received alerts email "failed to start (exit status 0) – /etc/init.d/user-sync: Starting user-sync... ok"
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This is for an outdated version of Hipchat Server
This article applies to a version of Hipchat Server which will be deprecated soon. After that period the version will no longer be supported.
You should upgrade to a more recent version of Hipchat Server as soon as you can to take advantage of new features, and security and bug fixes.
Problem
After a server upgrade to 2.0 build 1.4.1, admin started to receive the following alerts emails:
Action: alert
Desc: failed to start (exit status 0) – /etc/init.d/user-sync: Starting user-sync... ok
Event: Execution failed
Service: java
Cause
Starting from server v1.2 build 1.2.8, user-sync service is no longer used but the file exists on the server v2.0 build 1.4.1 hence admin received the misleading email. Note: This however does not imposed any harm to the server.
Resolution
Run the following command to disable alerts for user-sync:
sudo dont-blame-hipchat
service monit start
monit summary
monit stop user-sync || true
rm -f /etc/monit.d/user-sync.monitrc
/usr/sbin/update-rc.d -f user-sync remove || true
rm -f /etc/init.d/user-sync
dpkg --purge hc-user-sync
Internally, we're working on a script to clean this up in the upcoming Hipchat Server release.