Android mobile app disconnects and fails to reconnect with Send button grayed out

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This is for an outdated version of Hipchat Server

 This article applies to a version of Hipchat Server which will be deprecated soon. After that period the version will no longer be supported.

When will my version be deprecated?

The following versions have been deprecated:

  • Hipchat Server 1.3 (EOL Date: Aug 17, 2017)
  • Hipchat Server 2.0 (EOL Date: Jun 17, 2018)
  • Hipchat Server 2.1 (EOL Date: Dec 8, 2018)

The following version will be deprecated soon:

  • Hipchat Server 2.2 (EOL Date: May 30, 2019)

You can read more about Atlassian's End of Life policy here.

You should upgrade to a more recent version of Hipchat Server as soon as you can to take advantage of new features, and security and bug fixes.

Problem

When brought to the foreground, the Android app fails to reconnect to Hipchat Server. Manual reconnect doesn't help and the Send button is grayed out. 

Cause

Having duplicate mobile devices registered in the database could trigger this issue. There might be other cause we still don't know about. 

Workaround

  1. Logout of all your mobile device(s)
  2. Disable power saving mode and the Stay connected option
  3. Log in to the Hipchat Server's database from the command line.  
    1. For Hipchat Server versions older than 1.3.7, use this command:

      mysql -uroot -pyesiwishthat hipchat
    2. For versions 1.3.7 through 2.2.x, use this command:

      DBPASS=$(awk '/"pass"/ {gsub(/[",]/,"");print $2}' /hipchat/config/site.json) && mysql -uroot -p$DBPASS hipchat
  4. At the database prompt, run the below query to delete all mobile device(s) from the database for the affected user id: 

    DELETE FROM external_devices WHERE user_id=<your_user_id>;
  5. Delete the mobile device records from Redis: 

    redis-cli DEL mobile:<your_user_id>
  6. Login to Hipchat Server from the mobile device. 

 

Resolution

We still don't understand what could create duplicate mobile devices in the database. 

 

 

Last modified on Jan 19, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.