Confluence Glance preview unable to load in Hipchat clients

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

 

Problem

Confluence glance preview is unable to load in Hipchat clients with a "Can't load. Try again" error.    A sample screen shot is below:

Diagnosis

  • Access the Hipchat web client from a web browser.
  • Capture a HAR file following this documentation while reproducing the issue: Generating HAR files and analyzing web requests 
  • Check the Network requests from the HAR file for detailed errors.

Cause

  • There is a network restriction in place somewhere between Confluence and the Hipchat Server. 
  • Hipchat needs to be able to send requests to Confluence to get the glance status. 
  • If Confluence is not reachable by Hipchat, then the above symptom is observed.

Resolution

  • Check the organization's network configurations.
  • (info) This problem was noticed because Confluence was not exposed to the Internet (it was accessible only on the customer's internal network). Hipchat was exposed to the Internet but it was in a DMZ. There was access from the Hipchat Server in the DMZ to the Confluence server on the internal network. When users were on an external network, they were unable to see the glances. However while on the internal network or on VPN the glances were accessible. The problem was specific to the way the customer's network was configured.

 

Last modified on Jan 19, 2018

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