Directory Users Unable to Update Job Title
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This version of Hipchat Server is no longer supported
This article applies to a version of Hipchat Server which is beyond the Atlassian End of Life policy, and is no longer supported.
You should upgrade to a more recent version of Hipchat Server as soon as you can to take advantage of new features, and security and bug fixes. If possible, you should also consider deploying Hipchat Data Center instead.
Problem
Directory users are unable to update Job Title field in Hipchat Server.
- In Server v1.2 build 1.2.5: You can enter/add some texts in the field but when you hit 'Save', the field is not really updated. No errors in the UI but there's a message that says "Account information updated!"
- In Server v1.2 build 1.2.6, 1.2.7, 1.2.8: Job Title is editable but once you try to save it, there's a message in the UI that says "Please enter a title."
- In Server v1.3 build 1.3.1: Job Title is not editable by users or Admin. The field is greyed out.
Cause
Job Title field should be editable for all users in Hipchat Server including directory users.
Workaround
- In Server v1.2 build 1.2.5: Admin can update the Job Title field on user's behalf from Group Admin > Users > Click on the user > Update Job Title
- In Server v1.2 build 1.2.6 to 1.3.1: There is no workaround available. Job Title field is not editable at all by Admin. The field is greyed out.
Resolution
This issue no longer exists as of Hipchat v1.3 build 1.3.3. See Hipchat Server 1.x Release Notes for more information.
- User profiles no longer require the job title field to be filled