File Attachments and Emoticons on Hipchat Server are Missing after a Migration.
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
This is for an outdated version of Hipchat Server
This article applies to a version of Hipchat Server which will be deprecated soon. After that period the version will no longer be supported.
You should upgrade to a more recent version of Hipchat Server as soon as you can to take advantage of new features, and security and bug fixes.
Problem
After migrating a Hipchat Server Virtual Machine to a new location, file attachments and emoticons are missing from all chat rooms.
Cause
- It was discovered that on this specific server instance, the server administrator had created a custom mount point on the Hipchat Server to store all files. This is not recommended or supported.
- Hipchat Server, by default, expects to find all files inside the /file_store directory.
- The directory used for the custom mount point was using a different name (/hipchat_storage in this case)
- At one time there was a symbolic link between /file_store and /hipchat_storage but the symbolic link had somehow been broken during the migration.
Environment
- Hipchat Server 2.2.3 and newer.
Resolution
Although custom mount points are not supported, it is possible to reestablish the symbolic link using the following commands:
- Snapshot the current server virtual machine instance prior to executing the next steps. This will give the admin something to roll back to in case something goes wrong.
- Log in to the command line, gain root privilges, and remove the current /file_store directory:
sudo dont-blame-hipchat rm -rf /file_store
Create a symbolic link using this command:
ln -sT /hipchat_storage /file_store
- Run hipchat upgrade --restart to restart all services on the Hipchat Server. This should complete without an error or any complaints about chef failing.
- Log completely out of all chat sessions, log back in again, and check to see if the emoticons and file attachments are visible again.