Hipchat limited connectivity in Jira Server

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

On the global configuration screen for the Hipchat integration the connection status is showing up as LIMITED

Cause

This is caused because Hipchat cannot make a direct connection to Jira Server.

There are three possible connection states 

  • NOT CONNECTED Jira Server cannot make a connection to Hipchat (https://api.hipchat.com/, or your Hipchat Server instance).
  • LIMITED Jira Server can make a connection to Hipchat but Hipchat cannot make a connection back to Jira Server.
  • CONNECTED Jira Server can make a connection to Hipchat and Hipchat can make a connection back to Jira Server.

Jira Server only sends notifications to Hipchat and so will function correctly in LIMITED mode, however future versions of Jira Server might require CONNECTED to offer full functionality.

There are two common causes of Limited mode:

  1. Jira Server is behind a firewall that is preventing Hipchat from being able to contact Jira Server.
  2. Hipchat was configured with the wrong base URL.

Resolution

Jira Server is behind a firewall

If you are hosting Jira Server behind a firewall you won't be able to get Jira Server into the CONNECTED state without putting Jira on the other side of the firewall.

Jira Server isn't behind a firewall

It is likely that the hostname Hipchat is using to contact Jira Server is wrong, You can check what hostname is being used by going to the integrations admin screen in Hipchat https://<your-hipchat-url>/admin/addons, When you find Jira Server in the list of addons you should be able to see the hostname of Jira in the integration name.

If you weren't using a fully qualified domain name when you connected the integration Hipchat will be trying to use that URL to contact Jira Server.

Last modified on Feb 15, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.