Updating the license fails with "Cannot write license to file, please contact Hipchat support"

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When you try to update Hipchat Server license through the web interface, you will be presented with the following error on the https://<FQDN>/server_admin/license

Diagnosis

  • The directory of /hipchat/config/btf_license.json has the correct permissions:

    admin@hipchat:~$ ls -lh /hipchat/config/btf_license.json
    -rw-r--r-- 1 root root 1.2K Jan 16 13:42 /hipchat/config/btf_license.json
  • The license can be updated through the command line interface through the hipchat license - i command
  • Run the following command to verify the permission given to the /tmp/ folder. 

    sudo dont-blame-hipchat
    /home/admin# ll -d /tmp/
  • By default, the following permissions should be displayed:

    root@hipchat:/home/admin# ll -d /tmp/
    drwxrwxrwt 8 root root 4096 Mar 20 08:39 /tmp/
  • If the output differs from above, it means that the directory permissions have been changed.

Cause

The directory permission changes causes the write operation to fail. 

Resolution

  1. Change the permissions of the directory back to the default using the following set of commands:

    sudo dont-blame-hipchat
    chown root:root /tmp
    chmod 777 /tmp
  2. Verify that the license can be updated through the user interface.

 

Last modified on Jan 19, 2018

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