User directory sync fails with LDAP Error Code 49
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Synchronisation or user directory test connection failed with LDAP error code 49.
Cause
This is LDAP specific error. There could be many reasons for this issue. Please check the error's number and "data" code (in the example above, error code 49 and data code 52e) and match it with the description in the following table:
Data Code | Description |
---|---|
525 | user not found |
52e | invalid credentials |
530 | not permitted to logon at this time |
531 | not permitted to logon at this workstation |
532 | password expired (remember to check the user set in osuser.xml also) |
533 | account disabled |
701 | account expired |
773 | user must reset password |
775 | user account locked |
In the example above, the error code is 52e which means user entered invalid credential.
Resolution
Since the issue is often originated from Active Directory, consult with the AD administrator for resolution.