Below are the system requirements and installation instructions for the Atlassian Connector for Eclipse.

On this page:

System Requirements

The following platforms are supported for the Atlassian Connector for Eclipse. Please see Supported Platforms - Atlassian Connector for Eclipse for further details.

Atlassian Products

JIRA (1)

(tick) 5.0+

(tick) [3.13+, 5.0) (Connector 3.0.x)

FishEye (1)

(tick) 2.2.x, 2.1.x, 2.0.x

Bamboo (1)

(tick) 2.2.4+

Eclipse IDE

Eclipse IDE (2)

(tick) 4.4.x, 4.3.x, 4.2.x, 3.7.x

Mylyn

Mylyn

(tick) 3.8.4+

Operating Systems

Microsoft Windows (including 64-bit)

(tick) XP/2003/Vista/7/8

Linux (x86/GTK)

(tick) Ubuntu 10.04+
i.e. latest version

Apple Mac OS X

(tick) 10.5+

Notes

  • JIRA: Connector 3.0.8 and earlier, requires JIRA SOAP/RPC services running on the JIRA server (i.e. enable the RPC plugin).
  • Mylyn: If you do not already have Mylyn, it will be installed automatically when you install one of the Atlassian Connector's features. If you already have Mylyn installed, please check your version of Mylyn. If your version of Mylyn is earlier than 3.8.4, please upgrade to Mylyn 3.8.4 or newer.

Installation via the Eclipse Marketplace for Eclipse 3.7 (Indigo), 4.2 (Juno), 4.3 (Kepler), 4.4 (Luna)

You can install the Atlassian Connector for Eclipse via Eclipse Marketplace Client. Simply launch the Eclipse Marketplace Client ('Help' -> 'Eclipse Marketplace'), search for 'Atlassian' and follow the prompts to install.

Screenshot: Installing the Atlassian Connector for Eclipse via the Eclipse Marketplace Client

Installation via update site for Eclipse 3.7 (Indigo), 4.2 (Juno), 4.3 (Kepler), 4.4 (Luna)

You can also install the Connector via the Eclipse software updates manager, as described below.

To install the connector on a clean Eclipse IDE for Java Developers:

  1. Open the Eclipse software updates manager via 'Help', 'Install New Software'.
  2. Click 'Add'. The 'Add Site' window will display.
  3. Enter the details of the update site (see Eclipse Update Sites section above) and click 'OK'.
  4. The 'Available Software' screen will appear again. Select 'All Available Sites' in the 'Work with' dropdown list.
  5. Select both 'Atlassian Connector' categories:

  6. Click 'Next' and follow the installation prompts.
  7. Restart Eclipse when prompted.

Installation from the command line

Eclipse plugins can be installed from the command line without UI. That method allows to automate the installation process and is really useful when you want to repeat the installation several times (e.g. install plugin on many workstations).

Example usage:

./eclipse -nosplash -application org.eclipse.equinox.p2.director -repository http://update.atlassian.com/atlassian-eclipse-plugin/rest/nightly/e3.7 -installIU com.atlassian.connector.eclipse.feature.group
CODE

More details on the available options can be found on the Eclipse knowledge base pages: http://help.eclipse.org/juno/index.jsp?topic=/org.eclipse.platform.doc.isv/guide/p2_director.html

Eclipse Update Sites

Add the following URL to your Eclipse update sites:

There is also nightly update site available, for those who are keen to get the latest version of the connector. Builds are executed every night:

JIRA Compatibility note

Atlassian Connector 3.2.x is compatible with JIRA 5.0 and newer.

Atlassian Connector 3.2.x  consumes JIRA REST API instead of the old SOAP, RSS, WEB API used in version 3.0.8 and earlier.
JIRA REST API allows to retrieve more information from JIRA and gives more flexibility when comes to issue update. It allowed to significantly improve custom fields support. Issue editor is now able to display most of the custom field types and allows to edit them.

JIRA authentication note

Atlassian Connector 3.2.x uses HTTP Authentication to connect to JIRA instead of form authentication used in version 3.0.8 and earlier.

If your JIRA server is running behind a reverse proxy, and the reverse proxy requires separate HTTP authentication, the credentials for the reverse proxy must match the credentials for JIRA. Please also make sure that reverse proxy does not remove Authorization: header from the HTTP request.

For more information see release notes.

Offline Installation

If you cannot use our update site (e.g. due to firewall issues) or just prefer local installation, we offer a zipped version of the entire update site (you still may need to install Mylyn first as it is required by Atlassian Connector and not bundled in the zip).

  1. Download the Atlassian connector's from
    1. zipped update site (version 3.2.x)  - the same file for Eclipse 3.7, 4.2, 4.3, 4.4 or
    2. zipped update site (version 3.0.x) and JIRA below 5.0 or
    3. old zipped update site for Eclipse 3.6 and 3.5 or
    4. nightly zipped update site (latest version 3.2.x) - the same file for Eclipse 3.7, 4.2, 4.3, 4.4
  2. In Eclipse, open 'Help, 'Install New Software', 'Add', click the 'Archive' button and select the downloaded zip file.
  3. Continue with the installation steps as described for the regular update site — see instructions below.

Installing a Previous Version

Atlassian does not support older releases of the plugin.

Add the following URL to your Eclipse update sites:

The last version of the connector containing Crucible support is 2.3.0:

Troubleshooting the Installation

Please refer to the list of installation FAQ:

Related topics