The administrator user is getting email notifications every time a work item is created (Jira Connector) - Jira Align

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Summary

When Jira Align syncs to Jira, it logs the update in Jira as being done by the user administrator account instead of a service administrator account. The user administrator also receives email notifications for all changes.

The Jira Connector must be deactivated and the application link deleted and then recreated.

Environment

Jira Align

Diagnosis

When Jira Align syncs to Jira, it logs the update in Jira as being done by the user administrator account instead of a service administrator account. The user administrator also receives email notifications for all changes.

Cause

  1. OAuth Authentication was configured by an Administrator when they were logged into Jira with their own user administrator account.

  2. They changed it in the Jira Connector settings to the service administrator account, but there is no change to the problem.

Solution

  • Deactivate the Jira Connector

  • Delete the Jira Application Link to Jira Align

  • Recreate the Jira Application Link to Jira Align as per Jira integration setup section “OAuth authentication (Cloud and Server/Data Center)

  • Ensure that Jira was logged in as the service administrator account BEFORE clicking Request Jira for access.


Last modified on Apr 24, 2024

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