To get the latest and greatest features in JIRA, please upgrade to JIRA Software. Visit the Migration Hub for more information.

Integrating JIRA with FishEye

Atlassian FishEye allows you to track in JIRA the source code and changesets that correspond to your stories in JIRA, when you are using FishEye with your source-control repository. Integrating JIRA with Atlassian's Crucible allows you to view information about your code reviews in JIRA.

If you integrate FishEye/Crucible with JIRA, you will enable the following features:

Starting in JIRA 6.2.2 the Source and Reviews tabs are only displayed if JIRA is unable to display the associated information in the Development Tools panel.

Making it work

The procedure for connecting FishEye/Crucible to JIRA is described onIntegrating JIRA with Code Development Tools.

For additional information, see the FishEye and Crucible documentation:

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

20 Archived comments

  1. User avatar

    Kevin Parker

    When editing the FishEye configuration within JIRA Administration, I kept getting this error after updating:

    There was a problem connecting to your FishEye instance: Failed to authenticate with FishEye. See logs for more details.

    We use Crowd 2.x for authentication across these applications.  I created a crowd user called "jirauser" specifically for JIRA to use when integrating with FishEye, Crowd, etc.  I knew the username/password were correct.  I tried using my personal (administrator-level) account to test the JIRA to FishEye connection, and it worked perfectly.  The "jirauser" still gave the above error.

    The fix was to log in to FishEye directly as our "jirauser" account once, which in this case required CAPTCHA verification.  We have "Use CAPTCHA after 3 failed login attempts" set, so evidently we had the wrong password in during initial setup.  We had to log in to clear the blocked account.

    Now the above error is gone when updating the FishEye--JIRA configuration and it is working well.

    28 May 2010
  2. User avatar

    Alfred Lam

    I initially registered a fisheye-A in JIRA 4.1.2 and then fisheye-B. Now fisheye-A server has been decommed. How can I make fisheye-B become primary since there is no delete button to remove fisheye-A?

    13 Dec 2010
  3. User avatar


    You have to go in http://localhost:8060/admin and in server settings Edit Server Settings Enable the Remote API.

    24 Jan 2011
    1. User avatar


      They really need to put this step in the instructions!!!


      19 Apr 2012
  4. User avatar


    Re Step 1

    If basic authentication is in place it seems that bug JRA-23997 prevents the wizard from completing.

    I was able to work around this bug by adding the following lines to my apache config: # this section is required to work around bug JRA-23997
    Order deny,allow
    Deny from all
    Allow from <source server ip>
    Satisfy anyIs there a better / official solution to this?

    25 May 2011
  5. User avatar

    Andres Altamirano

    Is it possible to integrate an instance of jira and fisheye of the Atlassian plugin sdk? Does this steps apply to that?

    02 Aug 2011
  6. User avatar

    Alter Lagos

    I have a problem when I'm trying to create an Application link to fisheye. I've followed all the steps described here and in the browser don't show some apparent problem. The servers are fully trusted and the users are different in each application, but when I finished the application link creation, in the log show:

    2011-08-09 12:25:02,053 http-8091-14 WARN alter 744x1067x1 woqhud nnn.nnn.nnn.nnn /rest/applinks/1.0/applicationlinkForm/createAppLink [apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm=""}
    2011-08-09 12:25:02,218 http-8091-14 WARN alter 744x1067x1 woqhud nnn.nnn.nnn.nnn /rest/applinks/1.0/applicationlinkForm/createAppLink [apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm=""}
    2011-08-09 12:25:02,219 http-8091-14 WARN alter 744x1067x1 woqhud nnn.nnn.nnn.nnn /rest/applinks/1.0/applicationlinkForm/createAppLink [jirafisheyeplugin.config.fisheye.FishEyeInstanceManagerImpl] Request to '' returned status code 401. Assuming FishEye+Crucible both available
    2011-08-09 12:25:02,527 http-8091-14 ERROR alter 744x1067x1 woqhud nnn.nnn.nnn.nnn /rest/applinks/1.0/applicationlinkForm/createAppLink [jirafisheyeplugin.domain.fisheye.FishEyeManagerImpl] Error retrieving repositories for '' Error in remote call to 'dev' ( [AbstractRestCommand{path='api/rest/repositories', params={}, methodType=POST}] : anon access forbidden
    	at com.atlassian.jirafisheyeplugin.domain.fisheye.FishEyeManagerImpl.getRepositories(
    	at com.atlassian.jirafisheyeplugin.domain.fisheye.FishEyeManagerImpl.updateInstanceRepositories(
    	at com.atlassian.jirafisheyeplugin.domain.fisheye.FishEyeManagerImpl.refresh(
    	at com.atlassian.jirafisheyeplugin.config.RefreshManagerImpl.refreshAll(
    	at com.atlassian.jirafisheyeplugin.config.fisheye.FishEyeInstanceManagerImpl.fetchRepositoryAndProjectLists(
    	at com.atlassian.jirafisheyeplugin.config.fisheye.FishEyeInstanceManagerImpl.create(
    	at com.atlassian.jirafisheyeplugin.config.ual.ApplicationLinkEventListener.onCreate(
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    All this despite that the browser shows that the two way link was created correctly using OAuth. Later, if I create a link between a jira project and a fisheye repository, simply the project doesn't show the source tab ("view version control" is enabled for the used profile)
    If I go to the fisheye plugin configuration page, it shows "Repository list last refreshed : never" so if i try to make a cache refresh, shows in the screen the error message:

    Could not get repositories for instance Error in remote call to 'dev' (
    [AbstractRestCommand{path='api/rest/repositories', params={}, methodType=POST}\] : anon access forbidden

    The anonymous access is correctly configured in fisheye.If I put in my explorer the address the response is the following xml:

    But if i put the address in an explorer without session cookies or something like "curl" from my computer terminal or the jira server I received:

    BTW, jira is an upgraded version from v4.2.4-b591#591 to v4.4#649-r158309 and fisheye Version:2.6.1 Build:20110621071349 2011-06-22

    What other things can I do?
    Thanks in advance

    09 Aug 2011
    1. User avatar

      Alter Lagos

      I've resolved enabling Basic access and disabling OAuth and Trusted Applications

      At least now it works. Greets

      09 Aug 2011
      1. User avatar

        Marcel Trautwein alias childno͡.de

        That's not a solution, that's a dirty workaround and will not work for some use-cases. Also a dedicated basic user must be set and will count down a user license ;/

        Currently investigating this problem, leads me to which won't work when using mod_jk

        25 Jan 2012
    1. User avatar


      you  maybe not set "remove api" on in fisheye

      09 Apr 2012
  7. User avatar

    Borek Bernard

    Step 2.4 is incorrect, there is no "Edit Primary Configuration" button anywhere. You can get there from the Administration > Plugins > Application links section.

    14 Feb 2012
  8. User avatar


    How can I map fisheye repo to a Jira Project programatically via any API(REST/SOAP) or something?

    The Jira version we are using is  4.4.5. In earlier versions of Jira it was easy to map them via AssociateFishEyeReps.jspa page. It looks like that has changed in Jira 4.4.5

    23 Apr 2012
  9. User avatar


    After Step 1 I couldn't able to perform any further steps. None of them are applicable for JIRA 5.2 with Fisheye 2.9.2. Maybe there is something wrong with previous configurations cuz I could only be able to integrate FishEye with JIRA by creating an application link using JIRA administration menus. That is to say, I couldn't able to integrate them by using FishEye setup wizard. (Using Windows env. by the way)

    15 Jan 2013
  10. User avatar

    Patricia Goldweic

    Is there a way to refer to an arbitrary source file within a JIRA issue when using the JIRA-Fisheye integration? I tried to use the format: "source:<filename>" within text fields in the JIRA issue (as described in some other documentation for the JIRA Studio product) but this didn't work. I wonder if it is a supported feature at all. Please clarify. thanks!

    08 Feb 2013
  11. User avatar

    Gaurav Mishra

    Is there a way to Search information on the source tab by using JIRA search or JQL?

    08 Apr 2013
  12. User avatar


    What Gaurav asked. Looking for a way to use JQL to search for Source changes.

    17 Apr 2013
  13. User avatar

    Fernando Meira

    Is it possible get commits in the 'Source' tab on a JIRA issue from other repositories than the default for the project?

    If so, how?

    02 Jul 2013
  14. User avatar

    cristian zuccala

    I wonder if what happened to someone who can not enter the administrator password with which to install? no way to reset it?

    23 Oct 2013
  15. User avatar

    David Tello

    I have associated a jira project with a crucible project. My question is, i can to create a new association between the same jira project with another crucible proyect? It could create some problem with the first association? Exists some limitation for create links between a jira project with more than one crucible project?


    25 Oct 2013
Powered by Confluence and Scroll Viewport